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§ 1. 
Trang 6

§ 2. Một số khái niệm cơ bản.

Câu 1. Cơ sở dữ liệu (CSDL) là
A.  tập hợp dữ liệu có liên quan với nhau chứa thông tin của một tổ chức, được lưu trên máy tính, để đáp ứng nhu cầu khai thác thông tin của nhiều người.  
B.  tập hợp dữ liệu chứa đựng các kiểu dữ liệu: ký tự, số, ngày/giờ, hình ảnh... của một chủ thể nào đó.  
C.  tập hợp dữ liệu có liên quan với nhau theo một chủ đề nào đó được lưu trên máy tính điện tử.  
D.  tập hợp dữ liệu có liên quan với nhau theo một chủ đề nào đó được ghi lên giấy.  
Câu 2. Hệ quản trị CSDL là  
A. phần mềm dùng tạo lập, lưu trữ một CSDL. 
B.  phần mềm dùng tạo lập, cập nhật và khai thác một CSDL.
C.  phần mềm dùng tạo lập CSDL.
D.  phần mềm để thao tác và xử lý các đối tượng trong CSDL.
Câu 3. Hãy nêu các ưu điểm khi sử dụng CSDL trên máy tính điện tử?
A. Gọn, nhanh chóng 
B. Gọn, thời sự (Cập nhật đầy đủ, kịp thời...) 
C. Gọn, thời sự, nhanh chóng 
D. Gọn, thời sự, nhanh chóng, nhiều nguời có thể sử dụng chung CSDL
Câu 4. Hoạt động nào sau đây có sử dụng CSDL?
A. Soạn thảo văn bản 
B. Trình chiếu một bài thuyết trình
C. Sử dụng công cụ vẽ hình Paint
D. Quản lí bán hàng

§ 3. Hệ Quản trị cơ sở dữ liệu.
Câu 5. Người nào đã tạo ra các phần mềm ứng dụng đáp ứng nhu cầu khai thác thông tin từ CSDL?
A. Người  lập trình ứng dụng	B. Người QTCSDL   
C. Người khai thác	D. Người dùng cuối
Câu 6. Người nào có vai trò quan trọng trong vấn đề phân quyền hạn truy cập sử dụng CSDL trên mạng máy tính?
A. Người lập trình	B. Người quản trị CSDL
C. Người bán hàng	D. Người dùng cuối
Câu 7. 
Người nào có vai trò trực tiếp trong sử dụng phần mềm ứng dụng phục vụ nhu cầu khai thác thông tin?
A. Người QTCSDL	B. Người  lập trình
C. Người bán hàng 	D. Người dùng cuối
Câu 8. Hãy nêu các bước xây dựng CSDL?
A. Kiểm thử → Khảo sát → Thiết kế.	
B. Khảo sát → Kiểm thử → Thiết kế.
C. Khảo sát → Thiết kế → Kiểm thử.
D. Thiết kế → Khảo sát → Kiểm thử.
Câu 9. Ngôn ngữ định nghĩa dữ liệu bao gồm các lệnh cho phép
A. Mô tả các đối tượng được lưu trữ trong CSDL.
B. Đảm bảo tính độc lập dữ liệu.
C. Khai báo kiểu, cấu trúc, các ràng buộc trên dữ liệu của  CSDL.
D. Khai báo kiểu dữ liệu của CSDL.

§ 4. Hệ quản trị Microsoft Ascess	
Câu 10. Tập tin trong Access đươc gọi là gì?
A.  Bảng	B.  Tập tin dữ liệu  
C.  Tập tin cơ sở dữ liệu	D.  Tập tin truy cập dữ liệu
Câu 11. Access là gì?
A. Là phần mềm công cụ
B. Là hệ QTCSDL do hãng Microsoft sản xuất
C. Là phần mềm ứng dụng
D. Là phần cứng
Câu 12. Để khởi động Access 2010 ta thực hiện:
A. Start \ (All) Programs \ Microsoft Office\ Microsoft Access 2010.
B. Start \  Microsoft Access 2010.
C. Start \ Microsoft Office\ Microsoft Access 2010.
D. Start \ (All) Programs \ Microsoft Office\ Microsoft Excel 2010.
Câu 13. Phần đuôi (phần mở rộng) của tên tập tin được tạo ra từ phần mềm MS Access 2010 là gì?
A.  DOC	B.  TXT
C.  XLS  	 D.  ACCDB
Câu 14. Trong Access có mấy đối tượng chính?
A. 4         B. 2         C. 1	D. 3
Câu 15. Hãy nêu các chức năng chính của Access?
A. Lập bảng, Biểu mẫu, báo cáo, khóa chính 	
B. Tính toán, lập mẫu, báo cáo, thiết kế bảng
C. Báo cáo, Thống kê, mẫu hỏi, lập bảng 
D. Tạo báo cáo, mẫu hỏi, lập bảng, lập biểu mẫu
Câu 16. Hãy sắp xếp các bước sau để được thao tác tạo CSDL mới?
(1) Nhấn chọn nút Browse để chọn nơi lưu trữ
(2) Chọn File → Blank Database  
(3) Nhập tên cơ sở dữ liệu
(4) Nhấn chọn nút create.
A. (2)  (1)  (3)  (4)	B. (1)  (2) (4)  (3)
C. (1)  (2)  (3) (4)	D. (2)  (3) (4)  (1)
Câu 17. Tên của tập tin trong Access bắt buộc  phải  đặt trước hay sau khi tạo CSDL?
A. Bắt buộc đặt tên tệp ngay rồi mới thao tác trên CSDL
B. Đặt sau khi tạo khóa chính  
C. Đặt trước khi tạo khóa chính
D. Đặt tên tệp sau khi đã tạo CSDL
Câu 18. Trong Access, để mở một CSDL đã có thao tác thực hiện lệnh nào sau đây là đúng?
A.  File/open/<tên tệp>
B.  Create Table in Design View  
C.  Create table by using wizard
D.  File/new/Blank Database
Câu 19. Để đổi tên bảng ta chọn tên bảng, rồi thực hiện thao tác nào?
A. Click phải → Rename	
B. → Home→ Rename
C. → File → Rename	
D. → Database Tools → Rename
Câu 20. Muốn xóa một bảng trong Access, ta chọn tên bảng cần xóa rồi thực hiện thao tác nào?
A. File → Delete	B.  Insert → Rows
C. Click phải → Rename	D.  Click phải → Delete
Câu 21. Để lưu cấu trúc bảng ta thực hiện thao tác nào?
A. Format → Save	B.  Tools → Save	
C. View → Save	D.  File → Save
Câu 22. Dữ liệu của CSDL được lưu trữ ở
A. Query	B. Form
C. Table	D. Report
Câu 23. Trong Access, 1 Database có bao nhiêu bảng:  
A. Chỉ có 1	B. Tối đa 3
C. Tối thiểu 2	D. Tùy ý
Câu 24. Kết thúc phiên bản làm việc với Access ta thực hiện thao tác nào?
A. → Format → Save	B. → File → Close
C. → File → Open	D. → File → Exit
Câu 25. Trong CSDL đang làm việc, để tạo một bảng mới bằng cách tự thiết kế, thì thao tác thực hiện nào sau đây là đúng?
A. Create \ Table design	B. Create \ Query  design
C. Create \ Form design	D. Create \ Report design  
Câu 26. Khi tạo cấu trúc bảng, tên trường được nhập vào cột nào?
A. Field name	B. Data type
C. Field size	D. Format
Câu 27. 
Tên cột (tên trường) được viết bằng chữ hoa hay thường?
A.  Không phân biệt chữ hoa hay thường
B.  Bắt buộc phải viết thường  
C.  Bắt buộc phải viết hoa
D.  Tùy theo trường hợp
Câu 28. Data Type có nghĩa là gì?
A. Kiểu dữ liệu	B. Mô tả
C. độ rộng trưòng	D. Tên trường
Câu 29. Khi chọn dữ liệu cho các trường chỉ chứa một trong hai giá trị như gioitinh, đơn đặt hàng đã hoặc chưa giải quyết...nên chọn kiểu dữ liệu nào?
A. Number			B. Text
C. Auto Number  	D. Yes/No
Câu 30. Kiểu dữ liệu nào không có trong CSDL của Access?
A. Yes/No	B. Number
C. Integer.	D. Date/Time
Câu 31. Trong Access, kiểu dữ liệu số được khai báo như thế nào?
A. Curency 	B. Number 
C. Single 	D. Integer
Câu 32. Khi chọn kiểu dữ liệu cho trường số điện thoại nên chọn loại nào?
A. Number	B. Text
C. Autonumber	D. Date/Time
Câu 33. Khi chọn kiểu dữ liệu cho trường thành tiền (bắt buộc kèm theo đơn vị tiền tệ), nên  chọn loại nào  
A. Date/time	B. Currency
C. Text	D. Number
Câu 34. Trường Email có giá trị là: 1234@yahoo.com. Hãy cho biết trường Email có kiểu dữ liệu gì?
A. Currency    B. Text     C. AutoNumber    D. Number
Câu 35. Trong Access, dữ liệu kiểu đếm tăng tự động cho bản ghi mới là gì?
A. AutoNumber   B. Text   C. Currency   D. Number
Câu 36. Khi chọn  kiểu dữ liệu AutoNumber cho trường MaSo, thao tác nào sau đây không thực hiện được:
A. Không cần nhập vào trường MaSo
B. Mã số được cấp tự động
C. Được cấp lại Mã số đã xóa
D. Xóa Mã số khi không cần thiết
Câu 37. Trong Access, khoá chính dùng để
A. phân biệt hai dòng với nhau trong một bảng design
B. phân biệt hai Record trong một bảng
C. phân biệt hai field với nhau trong một bảng
D. Phân biệt hai bảng dữ liệu với nhau
Câu 38. Bảng đã được hiển thị ở chế độ thiết kế muốn thêm một trường vào bên trên trường hiện tại ta thực hiện thao tác nào?
A. File/New/Blank Database	
B. File/Save/<Tên tệp>	
C. Create / Table Design
D. Design / Insert Rows
Câu 39. Bảng đã được hiển thị ở chế độ thiết kế, muốn xóa trường đã chọn ta thực hiện thao nào?
A. Insert/Rows  	
B. File/New/Blank Database  
C. Design / Delete Rows
D. Create / Table 
Câu 40. Giả sử nhập dữ liệu “12A1” cho trường Ma_so. Vậy ta phải chọn trường Ma_so có kiểu dữ liệu nào?
A. Currency	B. Auto Number
C. Text	D. Number
Câu 41. Giả sử ta cần tạo bảng gồm các trường như sau:  STT, TENHANG, NGAYNHAP, DONGIA. Ta có thể khai báo lần lượt các kiểu dữ liệu theo thứ tự nào?
A. Text – Text – Yes/No – Number
B. Number – Date/Time – Text - Number
C. Text – Text – Text – Text
D. AutoNumber – Text – Date/Time – Number
Câu 42. Trường số lượng nên chọn kiểu dữ liệu nào?
A. Text	B. Number
C. Date/time	D.AutoNumber
Câu 43. Để chỉ định khoá chính cho bảng ta thực hiện thao tác nào?
A. → Database Tools → Primary key	
B. → External Data → Primary key
C. → Design → Primary key	
D. → File → Primary key 
Câu 44. Trong Access, kiểu dữ liệu Yes/No là kiểu gì?
A. Kiểu văn bản	B. Kiểu lôgic
C. Kiểu số	D. Kiểu ngày/giờ
Câu 45. Thuộc tính Validation Text của trường A sẽ quy định
A. dòng thông báo lỗi khi nhập giá trị của trường A không hợp lệ.
B. dòng thông báo xuất hiện khi con trỏ di chuyển vào cột A. 
C. điều kiện đòi hỏi để con trỏ có thể di chuyển vào cột A. 
D. điều kiện hợp lệ dữ liệu để giới hạn miền giá trị nhập vào trường A.
Câu 46. Phần thập phân của dữ liệu kiểu Long Interger có thể chứa tối đa bao nhiêu chữ số?
A. 1 chữ số	B. 7 chữ số
C. 15 chữ số	D. 0 chữ số
Câu 47. Qui định dữ liệu nhập kiểu ngày có dạng dd/mm/yy, chọn Format là gì?
A. Short Date 	B. Medium Date 
C. Long Date 	D. General
Câu 48. Biết trường DIEM có kiểu Number, chỉ nhận các giá trị từ 0 đến 10, hãy xác định thuộc tính Validation Rule của trường DIEM?
A. >0 or <=10	B. >=0 and <=10 
C. >[diem]>0 or [diem]<=10	D. 0<=[diem]<=10
Câu 49. Thuộc tính Validation Rule dùng để làm gì?
A. Thông báo lỗi khi nhập dữ liệu không hợp lệ
B. Kiểm tra tính hợp lệ của dữ liệu 
C. Qui định khoá chính 
D. Qui định tên của bảng
Câu 50. Tính chất nàu sau đây dùng để thiết lập giá trị mặc định cho một trường (Fields)?
A. Validation Rule 	B. Validation Text
C. Default Value	D. Required 
Câu 51. Tính chất Caption dùng để làm gì?
A. Đặt tên tiếng Việt đầy đủ cho cột, thay thế tên trường khi hiển thị bảng dưới dạng Datasheet view 
B. Ấn định số ký tự tối đa chứa trong trường đó 
C. Qui định số cột chứa số lẻ 
D. Định dạng ký tự gõ vào trong cột

§ 5. Các thao tác cơ bản trên bảng	   
Câu 52. Bảng đã được hiển thị ở chế độ trang dữ liệu, muốn xóa bản ghi hiện tại, ta thực hiện thao nào?
A.  Home/ Records/ Delete Record	
B.  Home/ Records/ Delete Column
C.  Delete	
D. Home/ Records/ New
Câu 53. Bảng đã được hiển thị ở chế độ trang dữ liệu, với một trường đã chọn, Muốn sắp xếp các bản ghi theo thứ tự tăng dần, ta thực hiện thao tác nào? 
A. Home/ Records/ New	
B. Home/ Sort & Filter/ Ascending  	
C. Home/ Records/ Delete Record	
D. Home/ Records/ Delete Column
Câu 54. Trong Access, nút lệnh này [image: ] có ý nghĩa gì?
A. Chỉ định khoá chính		
B. Khởi động Access
C. Mở tệp cơ sở dữ liệu	
D. Cài mật khẩu cho tệp cơ sở dữ liệu

Câu 55. Để lọc dữ liệu theo mẫu, điều kiện được trình bày dưới dạng mẫu, chọn nút lệnh nào?
A. [image: ]	B. [image: ]	C. [image: ]	D. [image: ]
Câu 56. Trong Access, nút lệnh [image: ] có chức năng gì?
A. Sắp xếp tăng dần.	  B. Sắp xếp giảm dần.
C. Lọc.	  D. Không làm gì cả
Câu 57. Trong Access, nút lệnh [image: ] có chức năng gì?
A. Sắp xếp tăng dần.   B. Lọc theo mẫu.
C. Sắp xếp giảm dần.  D. Lọc theo ô dữ liệu đang chọn.
Câu 58. Trong Access, nút lệnh [image: ] có chức năng gì?
A. Sắp xếp tăng dần.   B. Lọc theo mẫu.
C. Sắp xếp giảm dần.  D. Lọc theo ô dữ liệu đang chọn.

§ 6. Biểu mẫu	
Câu 59. Biểu mẫu là một đối tượng trong Access dùng để thực hiện công việc chủ yếu nào?
A. Xem, nhập, sửa dữ liệu	B. Kết xuất thông tin	
C. Lập báo cáo	D. Tìm kiếm thông tin  
Câu 60.  Trong Access đối tượng nào dùng để cập nhật, hiển thị dữ liệu với 1 khuôn mẫu giao diện phù hợp và thuận tiện?
A. Biểu mẫu (Form)	B. Bảng (Table)
C. Báo cáo (Report)	D. Mẫu hỏi (Query)
Câu 61. Câu nào không đúng  khi nói về khả năng của biểu mẫu?
A. Thực hiện các tính toán như tính trung bình cộng, tính tổng, đếm bản ghi.
B. Hiển thị dữ liệu trong bảng dưới dạng thuận tiện để xem nhập và sữa dữ liệu
C. Thực hiện các thao tác thông qua các nút lệnh
D. Thực hiện thao tác tìm kiếm, lọc, sắp xếp
Câu 62. Để tạo biểu mẫu bằng thuật sĩ,cần thao tác như thế nào?  
A. Create/ Forms/ Form wizard	
B. Create/ Forms
C. Create/ Forms/ Form design
D. Create/ Forms/ Blank Form
Câu 63. Để thay đổi cấu trúc của biểu mẫu, ta phải chọn chế độ làm việc nào?  
A. Design view	B. Datasheet view
C. Form view	D. Layout view
Câu 64. Để tạo nút lệnh (Command Button) bằng Wizard cho phép thêm mẫu tin mới, ta chọn loại hành động nào sau đây?
A. Record Operations, Add New Record 
B. Record Navigation, New Record 
C. Record Navigation, Add New Record 
D. Go to Record, New
Câu 65. Để tạo nút lệnh Command Button bằng Wizard cho phép tìm mẫu tin, ta chọn lệnh nào sau đây?
A. Record Navigation, Find Record 
B. Record Navigation, Find Next 
C. Record Operations, Find Record 
D. Record Operations, Find Next
Câu 66. Để tạo thoát biểu mẫu bằng  nút lệnh Command Button, ta chọn chức năng Close Form trong nhóm lệnh nào sau đây?
A. Record Navigation	B. Record Operations 
C. Form Operations	D. Application


§ 7. Liên kết giữa các bảng	
Câu 67.   Để tạo liên kết giữa các bảng, ta thực hiện thao tác nào?
A. Database Tools  Relationships   
B. Home  Relationships   
C. Create  Relationships     
D. File  Relationships  
Câu 68. Muốn xóa liên kết giữa hai bảng, trong cửa sổ Relationship ta thực hiện thao tác nào?
A. Chọn đường liên kết giữa hai bảng đó và nhấn Delete
B. Chọn hai bảng và nhấn Delete
C. Chọn một bảng và nhấn Delete
D. Chọn tất cả các bảng và nhấn Delete
Câu 69. Điều kiện để tạo mối liên kết giữa hai bảng là gì?
A. Trường liên kết của hai bảng phải cùng kiểu dữ liệu
B. Trường liên kết của hai bảng phải là chữ hoa
C. Trường liên kết của hai bảng phải là kiểu dữ liệu số
D. Trường liên kết của hai bảng phải khác nhau về kiểu dữ liệu
Câu 70. Quan hệ giữa hai bảng trong cơ sở dữ liệu Access có thể là gì?
A. Quan hệ một - nhiều 
B. Quan hệ nhiều - một 
C. Quan hệ một - một 
D. Quan hệ một - nhiều, một - một, nhiều – nhiều
Câu 71. Khi muốn thiết lập quan hệ (Relationship) giữa hai bảng thì phải thoả điều kiện gì? 
A. Có ít nhất một mẫu tin 
B. Có ít nhất ba trường 
C. Có chung ít nhất một trường 
D. Có chung ít nhất hai trường
Câu 72. Khi tạo ra các bảng trong cơ sở dữ liệu Access thì ta nên thực hiện theo trình tự nào?
A. Tạo liên kết  tạo khóa chính nhập liệu 
B. Tạo khóa chính  tạo liên kết  nhập liệu 
C. Tạo khóa chính  nhập liệu  tạo liên kết 
D. Nhập liệu  tạo khóa chính  liên kết
Câu 73. Sắp xếp các bước theo thứ tự thực hiện để tạo liên kết giữa hai bảng
1. Hiển thị hai bảng muốn tạo liên kết 
2. Mở cửa sổ Relationships 
3. Kéo thả trường liên kết giữa hai bảng 
4. Kích vào nút create 
A. 2-1-4-3 	B. 2-4-3-1 
C. 2-1-3-4	D. 2-3-4-3

§ 8. Truy vấn dữ liệu	
Câu 74. Mẫu hỏi thường được dùng để
A. lưu dữ liệu.               B. thực hiện phép tính toán.
C. báo cáo.                    D. thống kê.
Câu 75. 
Mẫu hỏi là đối tượng nào trong Access?
A. Macro                       B. Query
C. Form                         D. Report
Câu 76. Trong cấu trúc của mẫu hỏi, ta đặt điều kiện tại mục nào?
A. Table     B. Show        C. Criteria    D. Field
Câu 77. Tên trường là toán hạng trong biểu thức số học được đặt trong ký hiệu nào?
A. [ ] 	B. { } 	C. < > 	D. ( )
Câu 78. Khi tạo truy vấn, muốn sắp xếp dữ liệu theo chiều tăng hoặc giảm thì trong vùng lưới ta chọn nào? 
A. Index 	B. Index and Sort
C. Sort	D. Show
Câu 79. Khi tiến hành tạo Query, bước quan trọng nhất là gì? 
A. Chọn trường để sắp xếp 
B. Chọn kiểu trình bày báo cáo 
C. Chọn nguồn dữ liệu 
D. Chọn trường để phân nhóm
Câu 80. Chọn phát biểu đúng nhất trong các phát biểu sau: Khi tạo truy vấn, nếu có 2 hay nhiều bảng có cùng tên trường thì 
A. ta không thể cho hiển thị tất cả các trường đó.
B. ta phải đổi tên cho các trường đó.
C. truy vấn không thể thực hiện được.
D. vẫn tạo truy vấn bình thường.
Câu 81. Nguồn dữ liệu cho một Query là gì?
A. Table, Query	B. Query 
C. Report 	D. Module
Câu 82. Trong cửa sổ thiết kế Query, Để hiện hay ẩn một cột khi chạy Query ta phải sử dụng dòng nào? 
A. Show 	B. Sort 	C. Criteria 	D. Total
Câu 83. Khi tạo truy vấn, muốn sắp xếp dữ liệu theo chiều tăng hoặc giảm thì trong vùng lưới ta chọn ở mục?
A. Index 	B. Index and Sort
C. Sort 	D. Show
Câu 84. 
Trong một truy vấn ta phải chọn ít nhất bao nhiêu Table? 
A. 1	B. 2 	C. 3 	D. 4
Câu 85. Truy vấn dữ liệu có nghĩa là
A. in dữ liệu.
B. tìm kiếm và hiển thị dữ liệu.
C. lưu trữ dữ liệu.
D. thống kê dữ liệu.
Câu 86. Trong truy vấn để tính tổng, ta dùng hàm nào trong Access? 
A. SUM 	B. AVG 	C. MIN 	D. MAX
Câu 87. Trong truy vấn để tính trung bình, ta dùng hàm nào trong Access? 
A. SUM 	B. AVG 	C. MIN 	D. MAX
§ 9.  Báo cáo & kết xuất báo cáo	
Câu 88. Để tạo một báo cáo bằng thuật sĩ, ta thực hiện lệnh nào? 
A. Create/ Form wizard 
B. Create/ Table wizard 
C. Create/ Report wizard 
D. Create/ Query wizard
Câu 89. Trong Acces, để kết thúc việc tạo báo cáo, ta nhấn nút lệnh nào? 
A. Quit 	B. Exit 	C. Finish 	D. Close
Câu 90. Trong Acces, đối tượng Report được dùng để làm gì? 
A. Nhập dữ liệu 
B. Sửa cấu trúc bảng 
C. Chỉnh sửa dữ liệu 
D. Tổng hợp dữ liệu
Câu 91. Khi tiến hành tạo Report, bước quan trọng nhất là gì? 
A. Chọn trường để sắp xếp 
B. Chọn kiểu trình bày báo cáo 
C. Chọn nguồn dữ liệu 
D. Chọn trường để phân nhóm


1. TỰ LUẬN
1. Thiết kế cấu trúc (design) 3 bảng CSDL quản lý KINH_DOANH:
Khach_hang(ma_kh, ho_ten)
Mat_hang(ma_mat_hang, ten_mat_hang, don_gia)
Hoa_don(so_don, ma_kh, ma_mat_hang, so_luong)
1. Thiết kế cấu trúc (design) 3 bảng trong CSDL quản lý học tập: 
hoc_sinh(ma_HS, ho_ten)
mon_hoc(ma_mon_hoc, ten_mon_hoc)
bang_diem(id, ma_HS, ma_mon_hoc, ngay_kiem_tra, diem_so)


1. Thiết kế cấu trúc (design) 3 bảng trong CSDL quản lý điểm của một kỳ thi tuyển sinh:
thi_sinh(sbd, ho_ten, ngay_sinh, gioi_tinh, truong)
danh_phach(sbd, phach)
diem_thi(phach, diem)
1. Thiết kế cấu trúc (design) 3 bảng trong CSDL quản lý thư viện:
sach(ma_so_sach, ten_sach, so_trang)
nguoi_muon(so_the, ho_ten)
[bookmark: _GoBack]muon_sach(id, so_the, ma_so_sach, ngay_muon)
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